WPS提示no necessary symbol fonts

系统: centos7 64
软件:WPS 10.1.0.6757


原来在linux系统内进行word文档编译的时候一直是使用google在线文档编译来进行的,其他的office套件都与微软的office兼容性不佳,早期的wps也存在各种小问题.今天发现wps for linux偷偷的更新过了,准备安装一个常常鲜.
官网下载好rpm包后安装分简易.打开还是提示字体缺失(linux因为版权问题无法避免),我们只能手动下载了.
链接: https://pan.baidu.com/s/1IJTAGoe0uqlmb07YLHy0fw 提取码: uht9 复制这段内容后打开百度网盘手机App,操作更方便哦
下载完成后使用以下命令直接安装,PS:一定要wps-office文件夹命名

sudo unzip wps_symbol_fonts.zip -d /usr/share/fonts/wps-office

打开wps后发现无法输入中文

sudo vim /usr/bin/wps       编译器打开wps启动脚本进行编译

在/bin/bash下一行添加以下内容

export XMODIFIERS="@im=ibus"
export QT_IM_MODULE="ibus"

重启后生效